-
Notifications
You must be signed in to change notification settings - Fork 1
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Create RegEx-Patterns-and-Intro-to-Databases.py
- Loading branch information
1 parent
85d885e
commit dc48235
Showing
1 changed file
with
60 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,60 @@ | ||
""" | ||
Task | ||
Consider a database table, Emails, which has the attributes First Name and Email ID. Given rows of data simulating the Emails table, print an alphabetically-ordered list of people whose email address ends in . | ||
Input Format | ||
The first line contains an integer, , total number of rows in the table. | ||
Each of the subsequent lines contains space-separated strings denoting a person's first name and email ID, respectively. | ||
Constraints | ||
Each of the first names consists of lower case letters only. | ||
Each of the email IDs consists of lower case letters , and only. | ||
The length of the first name is no longer than 20. | ||
The length of the email ID is no longer than 50. | ||
Output Format | ||
Print an alphabetically-ordered list of first names for every user with a gmail account. Each name must be printed on a new line. | ||
Sample Input | ||
6 | ||
riya [email protected] | ||
julia [email protected] | ||
julia [email protected] | ||
julia [email protected] | ||
samantha [email protected] | ||
tanya [email protected] | ||
Sample Output | ||
julia | ||
julia | ||
riya | ||
samantha | ||
tanya | ||
""" | ||
# SOLUTION | ||
#!/bin/python3 | ||
|
||
import math | ||
import os | ||
import random | ||
import re | ||
import sys | ||
|
||
|
||
|
||
if __name__ == '__main__': | ||
names = [] | ||
N = int(input()) | ||
|
||
for N_itr in range(N): | ||
firstNameEmailID = input().split() | ||
|
||
firstName = firstNameEmailID[0] | ||
|
||
emailID = firstNameEmailID[1] | ||
if '@gmail.com' in emailID: | ||
names.append(firstName) | ||
print(*sorted(names), sep='\n') |