-
Notifications
You must be signed in to change notification settings - Fork 1
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
1 parent
c8c91e9
commit ccb4ced
Showing
1 changed file
with
67 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,67 @@ | ||
""" | ||
John works at a clothing store. He has a large pile of socks that he must pair by color for sale. Given an array of integers representing the color of each sock, determine how many pairs of socks with matching colors there are. | ||
For example, there are socks with colors . There is one pair of color and one of color . There are three odd socks left, one of each color. The number of pairs is . | ||
Function Description | ||
Complete the sockMerchant function in the editor below. It must return an integer representing the number of matching pairs of socks that are available. | ||
sockMerchant has the following parameter(s): | ||
n: the number of socks in the pile | ||
ar: the colors of each sock | ||
Input Format | ||
The first line contains an integer , the number of socks represented in . | ||
The second line contains space-separated integers describing the colors of the socks in the pile. | ||
Constraints | ||
where | ||
Output Format | ||
Return the total number of matching pairs of socks that John can sell. | ||
Sample Input | ||
9 | ||
10 20 20 10 10 30 50 10 20 | ||
Sample Output | ||
3 | ||
Explanation | ||
sock.png | ||
John can match three pairs of socks. | ||
""" | ||
# SOLUTION | ||
#!/bin/python3 | ||
|
||
import math | ||
import os | ||
import random | ||
import re | ||
import sys | ||
from collections import Counter | ||
# Complete the sockMerchant function below. | ||
def sockMerchant(n, ar): | ||
Sum = 0 | ||
for value in Counter(ar).values(): | ||
Sum += value//2; | ||
return Sum | ||
|
||
if __name__ == '__main__': | ||
fptr = open(os.environ['OUTPUT_PATH'], 'w') | ||
|
||
n = int(input()) | ||
|
||
ar = list(map(int, input().rstrip().split())) | ||
|
||
result = sockMerchant(n, ar) | ||
|
||
fptr.write(str(result) + '\n') | ||
|
||
fptr.close() |