From dc48235c7abd2ab19ab2758b77b2a5e47fdfd15d Mon Sep 17 00:00:00 2001 From: Saksham Garg <55405810+sakshusakshusakshu@users.noreply.github.com> Date: Tue, 30 Jun 2020 14:43:40 +0530 Subject: [PATCH] Create RegEx-Patterns-and-Intro-to-Databases.py --- RegEx-Patterns-and-Intro-to-Databases.py | 60 ++++++++++++++++++++++++ 1 file changed, 60 insertions(+) create mode 100644 RegEx-Patterns-and-Intro-to-Databases.py diff --git a/RegEx-Patterns-and-Intro-to-Databases.py b/RegEx-Patterns-and-Intro-to-Databases.py new file mode 100644 index 0000000..d8f7ca8 --- /dev/null +++ b/RegEx-Patterns-and-Intro-to-Databases.py @@ -0,0 +1,60 @@ +""" +Task +Consider a database table, Emails, which has the attributes First Name and Email ID. Given rows of data simulating the Emails table, print an alphabetically-ordered list of people whose email address ends in . + +Input Format + +The first line contains an integer, , total number of rows in the table. +Each of the subsequent lines contains space-separated strings denoting a person's first name and email ID, respectively. + +Constraints + +Each of the first names consists of lower case letters only. +Each of the email IDs consists of lower case letters , and only. +The length of the first name is no longer than 20. +The length of the email ID is no longer than 50. +Output Format + +Print an alphabetically-ordered list of first names for every user with a gmail account. Each name must be printed on a new line. + +Sample Input + +6 +riya riya@gmail.com +julia julia@julia.me +julia sjulia@gmail.com +julia julia@gmail.com +samantha samantha@gmail.com +tanya tanya@gmail.com +Sample Output + +julia +julia +riya +samantha +tanya +""" +# SOLUTION +#!/bin/python3 + +import math +import os +import random +import re +import sys + + + +if __name__ == '__main__': + names = [] + N = int(input()) + + for N_itr in range(N): + firstNameEmailID = input().split() + + firstName = firstNameEmailID[0] + + emailID = firstNameEmailID[1] + if '@gmail.com' in emailID: + names.append(firstName) + print(*sorted(names), sep='\n')