-
Notifications
You must be signed in to change notification settings - Fork 1
/
ReverseArrayHR.c
52 lines (38 loc) · 944 Bytes
/
ReverseArrayHR.c
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
/*
Given an array,arr of size n, reverse it.
Example: If array,arr = [1,2,3,4,5] , after reversing it, the array should be,arr = [5,4,3,2,1] .
Input Format
The first line contains an integer, , denoting the size of the array. The next line contains space-separated integers denoting the elements of the array.
Output Format
The output is handled by the code given in the editor, which would print the array.
Sample Input 0
6
16 13 7 2 1 12
Sample Output 0
12 1 2 7 13 16
Sample Input 1
7
1 13 15 20 12 13 2
Sample Output 1
2 13 12 20 15 13 1
Sample Input 2
8
15 5 16 15 17 11 5 11
Sample Output 2
11 5 11 17 15 16 5 15
*/
// SOLUTION
#include <stdio.h>
#include <stdlib.h>
int main()
{
int num, *arr, i;
scanf("%d", &num);
arr = (int*) malloc(num * sizeof(int));
for(i = 0; i < num; i++) {
scanf("%d", arr + i);
}
for(i = num-1; i>-1; i--)
printf("%d ", *(arr + i));
return 0;
}