-
Notifications
You must be signed in to change notification settings - Fork 1
/
PointerHR.cpp
62 lines (45 loc) · 1.66 KB
/
PointerHR.cpp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
/*
A pointer in C is a way to share a memory address among different contexts (primarily functions). They are primarily used whenever a function needs to modify the content of a variable, of which it doesn't have ownership.
In order to access the memory address of a variable, , we need to prepend it with sign. E.g., &val returns the memory address of .
This memory address is assigned to a pointer and can be shared among various functions. E.g. will assign the memory address of to pointer . To access the content of the memory to which the pointer points, prepend it with a *. For example, *p will return the value reflected by and any modification to it will be reflected at the source ().
void increment(int *v) {
(*v)++;
}
int main() {
int a;
scanf("%d", &a);
increment(&a);
printf("%d", a);
return 0;
}
You have to complete the function void update(int *a,int *b), which reads two integers as argument, and sets with the sum of them, and with the absolute difference of them.
Input Format
Input will contain two integers, and , separated by a newline.
Output Format
You have to print the updated value of and , on two different lines.
P.S.: Input/ouput will be automatically handled. You only have to complete the void update(int *a,int *b) function.
Sample Input
4
5
Sample Output
9
1
Explanation
*/
// SOLUTION
#include <stdio.h>
#include <cstdlib>
#include <iostream>
void update(int *a,int *b) {
// Complete this function
*a = *a + *b ;
*b = abs(*a - *b - *b);
}
int main() {
int a, b;
int *pa = &a, *pb = &b;
scanf("%d %d", &a, &b);
update(pa, pb);
printf("%d\n%d", a, b);
return 0;
}