-
Notifications
You must be signed in to change notification settings - Fork 1
/
ConditionalStatementsHR.cpp
129 lines (103 loc) · 2.67 KB
/
ConditionalStatementsHR.cpp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
/*
if and else are two of the most frequently used conditionals in C/C++, and they enable you to execute zero or one conditional statement among many such dependent conditional statements. We use them in the following ways:
if: This executes the body of bracketed code starting with if evaluates to true.
if (condition) {
statement1;
...
}
if - else: This executes the body of bracketed code starting with if evaluates to true, or it executes the body of code starting with if evaluates to false. Note that only one of the bracketed code sections will ever be executed.
if (condition) {
statement1;
...
}
else {
statement2;
...
}
if - else if - else: In this structure, dependent statements are chained together and the for each statement is only checked if all prior conditions in the chain evaluated to false. Once a evaluates to true, the bracketed code associated with that statement is executed and the program then skips to the end of the chain of statements and continues executing. If each in the chain evaluates to false, then the body of bracketed code in the else block at the end is executed.
if(first condition) {
...
}
else if(second condition) {
...
}
.
.
.
else if((n-1)'th condition) {
....
}
else {
...
}
Given a positive integer denoting , do the following:
If , then print the lowercase English word corresponding to the number (e.g., one for , two for , etc.).
If , print Greater than 9.
Input Format
A single integer denoting .
Constraints
Output Format
If , then print the lowercase English word corresponding to the number (e.g., one for , two for , etc.); otherwise, print Greater than 9 instead.
Sample Input 0
5
Sample Output 0
five
Explanation 0
five is the English word for the number .
Sample Input 1
8
Sample Output 1
eight
Explanation 1
eight is the English word for the number .
Sample Input 2
44
Sample Output 2
Greater than 9
Explanation 2
is greater than , so we print Greater than 9.
*/
// SOLUTION
#include <bits/stdc++.h>
#include<iostream>
#include <cstdio>
using namespace std;
int main()
{
int n;
cin >> n;
cin.ignore(numeric_limits<streamsize>::max(), '\n');
// Write Your Code Here
if(n>9)
{
cout<<"Greater than 9";
}
else if(n == 1){
cout<<"one";
}
else if(n == 2){
cout<<"two";
}
else if(n == 3){
cout<<"three";
}
else if(n == 4){
cout<<"four";
}
else if(n == 5){
cout<<"five";
}
else if(n == 6){
cout<<"six";
}
else if(n == 7){
cout<<"seven";
}
else if(n ==8){
cout<<"eight";
}
else if(n == 9){
cout<<"nine";
}
return 0;
}